BlackBerry Forums Support Community
              

Closed Thread
 
Thread Tools
Old 09-27-2012, 02:06 AM   #1
hibbert
Thumbs Must Hurt
 
Join Date: May 2007
Location: berlin, germany
Model: 8310
PIN: N/A
Carrier: vodafone
Posts: 163
Default NoClassDefFound after adding some vars

Please Login to Remove!

Hi,
in my App I have got some classes (wow) with some getters and setters(double wow).

When I develop my App and Test it on my Blackberry (BB 9360 v. 7.1) it is all fine.

But after adding some new vars to one of my classes I get the "NoClassDefFound" exception. I just add some new vars and try to run the App.

After removing the new vars it's still the same problem... wtf is BB doing?

Does anyone have some ideas? I'm using eclipse under win7 x64.

Thank you.
__________________
My English is so bad, that makes me nobody so quickly after
Offline  
Old 09-27-2012, 09:22 AM   #2
Dougsg38p
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Default Re: NoClassDefFound after adding some vars

The first thing to do is detemine which class it is complaining about.

This should be in your stack trace (simulator) or in the event log (device)
Offline  
Old 09-28-2012, 01:51 AM   #3
hibbert
Thumbs Must Hurt
 
Join Date: May 2007
Location: berlin, germany
Model: 8310
PIN: N/A
Carrier: vodafone
Posts: 163
Default Re: NoClassDefFound after adding some vars

It is while my MainScreen is initializing. There are no more information about this error :/

I wiped my device and tried to add a test-app, everything is fine. I try my app, still the same error :(
__________________
My English is so bad, that makes me nobody so quickly after
Offline  
Old 09-28-2012, 07:49 AM   #4
Dougsg38p
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Default Re: NoClassDefFound after adding some vars

Did you check the event log?

You can view it on the device or download via javaloader...

No way for anyone to help you with 1) no error info, and 2) no source code
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads for: NoClassDefFound after adding some vars
Thread Thread Starter Forum Replies Last Post
Having Issues adding contact from a message. HELP! Cheryll BlackBerry Help 1 06-17-2011 07:02 AM
BlackBerry Messenger - problem adding contacts Jadey General BlackBerry Discussion 98 09-05-2010 06:48 AM
Bes 5 - Wrong messaging server when adding users TRmartin BES Admin Corner 0 11-18-2009 02:09 PM
Im having trouble adding a menuitem to the mainscreen menu flameheels Developer Forum 5 07-22-2008 11:12 PM
Adding another carrier to BES ARXXBES BES Admin Corner 2 01-25-2008 09:19 AM


VINTAGE APPLE LITE VRAM 128K X 8 BOARD CARD 820-0522-A  With A Cable Connection. picture

VINTAGE APPLE LITE VRAM 128K X 8 BOARD CARD 820-0522-A With A Cable Connection.

$99.99



APPLE 820-0522-A 630-0895-B LITE VRAM 128K X 8 BOARD > picture

APPLE 820-0522-A 630-0895-B LITE VRAM 128K X 8 BOARD >

$149.99



128K RAM - APPLE - ORIGINAL APPLE prototype BOARD picture

128K RAM - APPLE - ORIGINAL APPLE prototype BOARD

$401.25



APPLE 630-0895-B  VRAM 128K X 8 BOARD CARD VINTAGE picture

APPLE 630-0895-B VRAM 128K X 8 BOARD CARD VINTAGE

$74.77







Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.