View Single Post
Old 12-20-2010, 07:49 PM   #8
Sabu Gopinath
New Member
Join Date: Sep 2010
Model: 9000
Carrier: Airtel
Posts: 6
Default Re: Enterprise mail not received but can send out mails

Now this is kind of weird. But before that, I did tell my Admin your suggestion. He says he tried disabling redirection and enabled only Inbox and Sent.
Over the weekend, I tried changing device. I borrowed a friends device. When I connected his device to desktop, I got the message that it was a different device registered against my mail account and if I would like to change it. On confirmation and new encryption key generation, it did an initial sync and I saw my mails on my device after a long time!! I tried Enterprise Activation but it kept failing for various reasons. I had to restore his device (had to get the IT Policy removed) and give the device back. Experiment remained inconclusive. Now comes the interesting part.
Just to see some mails on my device, I restored one on the old back ups on my device and connected Desktop software to the server. Again, I got the message about the device being different and on confirmation, a new encryption key was generated and it did the initial sync. All the old mails were removed and the mails were upto date on device and desktop. Then the Enterprise Activation started. None of the subsequent mails were delivered to the device. Now I had 125 unread mails in my Inbox, though slightly outdated. My observations below.
1)I had 125 unread mails in the device after the initial sync. It was synchronised with my desktop. I have not received any mails after Enterprise Activation.
2)I read 10 mails in my device. The "Read" status was updated in my LN.
3)I "looked up" and sent mails from my device or replied. These were reflected in my Desktop.
3)I deleted a few in my device after reading. I suspect, these were deleted in my desktop as well.Could not confirm.
4)I read all the mails in my Desktop. Deleted and archived in Desktop. The mails continued to remain in my Inbox of the device. But the status changed from "Unread" to "Read".

So I have 115 Read mails in my device Inbox now the last one dated last Sunday before I did Enterprise Activation.
Now I am wondering where the problem could be
1)BES is not pushing new updates to my device?
2)Some issue with the "IT Policy" and my device?
3)Some issue with the "Encryption Key" and Firewall?

Sorry for the long post. I thought I should include as much details as possible to improve my chances of resolution. I am perplexed.
Offline   Reply With Quote