BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   RIM Software (
-   -   Remove IT Policy (

ammatusk 04-10-2007 10:07 AM

Thanks so much
As a split-personality user (I am on BES at work and BIS for my personal BB), I have learned so much from this thread.

Initially, I tried wiping and although I blew out my personal data, it seemed that the policy didn't take.

Well, that's because I'm one of those "oh, it doesn't matter where the file is as long as I point to it" people. Yeah...didn't work.

So....went through it again and followed the directions to the letter and, surprise, surprise, it worked great.

I wanted to thank everyone who has been posting on this issue. The inability to load some apps (Google Maps, specifically) was driving me batty.

All fixed now, thanks to all of you!

raafter 04-10-2007 11:08 AM

If you have devices that "walk" from your organization and you want to ensure they are never used again you can contact RIM client care or t-support and have the pin blocked from their NOC.

The device will NEVER work again if that's the case. it isn't something that is used widely however it is available.

nyubi 04-15-2007 01:50 AM

i have a used pearl, it has it policy, after i followed above op described step, i finally can clear the it policy, disable password etc.

but the firewall still enable, can't be disable, but i still can edit the firewall option (install 3rd party apps, keystroke injection,etc) to allow..

am I good to go now ?

caseymandy560 04-20-2007 07:15 PM

This worked great. Thanks!!!

canmat 05-01-2007 06:09 PM

I have a blackberry 7100g I bought off ebay for my wife. I it has a security policy, but these steps may have to be a little modified for me.

I used the Cingular software here ->

BlackBerry Handheld Software v4.1.0.556 (Multilanguage)

Package Version:
Consisting of:
Software Platform:
File name: 7100E_PBrER4.1.0_rel556_PL1.8.0.154_A4.1.0.377_AWS .exe
File size: 36.42MB

It appears this is the latest software availible to me from cigular for my bb. It does not give me the HKEY_Current_Users\Software\Research In Motion\BlackBerry\PolicyManager as an option in the registry.

Heck, the only availible category is HKey _Current_Users\Software\Research In Motion\BlackBerry\Loader

I am a bit of a noob when it comes to this blackberry, but I'm having a good time. If you have any tips it would be greatly appreciated!

John Clark 05-01-2007 06:30 PM

Are you running Windows XP? Do you have Desktop Manager installed?

canmat 05-01-2007 06:53 PM

Is desktop manager in different package then what I downloaded? Yes I am in Win XP. I tried to download a newer operating system, but it did not have the software it needed for my device. Does desktop manager come in a stand alone version that will work with Package Version:, it wasn't an install option when I installed using custom install. I installed every option there was.

Thank you for your help!

John Clark 05-01-2007 07:01 PM

Download and Install Desktop Manager from here:

BlackBerry - BlackBerry - Sys Req V4-2 Pack 1

Then download and install the OS of your choice. If it's from a carrier other than the one your BB is branded to then delete the vendor.xml file after the installation of the OS.

canmat 05-01-2007 11:43 PM

Thank you very much! It worked like a charm, thank you so much for your help!

Carla_scotland 05-05-2007 04:22 PM

IT Policy removal on BB7230 / Vodafone / UK
Hello all from Glasgow, Scotland.

I have recently purchased a BB7230 off ebay, with SIMlock to Voafone(UK). I _dont_ have a BES or BIS account and have a Pay as You Go (pre-pay) Vodafone SIM. I mainly intend to use the BB as a Phone /PDA but a bit of TCP/IP access would be nice.

The Vodafone SIM works fine on GPRS in other mobile phones I can use my laptop and the IR port on my Nokia for internet access on most ports (80,21,23,8080 etc).

I found these very helpful forums via Google so rather than just ask for help I though I would share my learning so far for others to find - and then post my question immediately below this...

Removing the IT policy
I downloaded the BB desktop software but could not install applicatios so I followed the instructions here:
Other people have reported mixed results, but it worked fine for me and I can now download and install software via the desktop.

TCP / IP Access
I entered APN user:web, password:web (exactly the same as on my Nokia phone)

I have no Blackberry browser and know of no method to get it back so I then downloaded Opera Mini and installed it.

During first start up it goes through a number of staps before failing with an error:

The application operette$2dhifi has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your it policy.

Googling round a bit this seems to be due to a policy restriction, that is turned on by DEFAULT in the BLANK profile to DISABLE split-pipe-connections. See:]

AFAIK since OS version 3.61 an application can only connect via wither the BES/MDS _or_ TCP/IP - the first service it connects to (even if it does not work) is remembered unless you remove all the software and reinistall. See link below for how to make the BB "forget":

So I then installed a trial of IM+ that allows you to select the transport mode TCP/IP or MDS/BES or BIS and I also installed a trial of Idokorro Mobile SSH that allows you to pick TCP/IP, BIS or BES/MDS.

In both cases with the software set it TCP/IP I get as far as the "arrows" flashing in the top right of the screen the the BB transmits (I can hear the interference on a radio) with no firewall problems.

Carla_scotland 05-05-2007 04:23 PM

BB 7230 / Vodafone(UK) / will not connect
And now the questions:

I have a good signal strength 2-3 blobs on the meter, Given GPRS works on the SIM in another phone I am assuming there is nothing wrong with the Vodafone account...

but the BB fails to connect - the arrows in the top right flash for a while with "half thickness" (if this makes sence) than stop.

Anyone got any suggestions - can anyone explain what the "arrows" mean.


John Clark 05-05-2007 04:28 PM

Wirelessly posted (BB 8860: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) BlackBerry8100/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Yes, your issue is due to a leftover IT policy. As far as I know, there is no way to remove the firewalls. In order to access data you need a BB data plan. Without a BB data plan, no data. However, as you say it is sometimes possible to access the internet with Opera and a GPRS data plan. However, with the policy in place its very possible you will never be able to access this. The only way to remove all policy is to connect the BB back to a bes and push a new blank policy to it.

nosralr 05-26-2007 12:35 PM

Quoting the first post in this thread:

Step 3
Wipe your Blackberry, creating a backup if necessary. Select Options/Security/Wipe on the Device.
If this option is unavailable, you may have to install the latest software on your Blackberry. You need to Download and install the latest OS for your device. Connect your device, open the Desktop Manager, select Application Loader, and follow the prompts.

I have a 6230. I clicked the above link to install the latest OS on my device. When I go there I find a huge list of carriers. However, some have a lock after them and some have another icon. For instance, Etisalat doesn't have a lock. When I click Etisalet it displays 4.2 OS for the Pearl 8100. Will that work on my 6230? Or what do I want? I am not using any of the carriers listed there, as I am in Bangladesh. Thanks.

John Clark 05-26-2007 12:43 PM

The 8100 OS will NOT work on a 6230. The 6230 is a pretty old device.

BTW, your profile says "7100t."

nosralr 05-26-2007 12:43 PM

One more thing. I have tried to wipe my 6230 a few times. When I installed Opera Mini on it I got to step 6 and it ran into the IT policy program. So I then wiped my 6230 BB but Opera Mini is still on there. Why would that be after wiping it?

John Clark 05-26-2007 12:57 PM

Because "wiping" from the handheld only removes data, not programs or OS.

nosralr 05-26-2007 01:44 PM

Yes, I know my profile says "7100t." I guess it should say, "7100t, 7100g, and 6230!"

I have not be able to get Opera to work on any one of them. I am at my wits end.

What can I try next? I have wiped the 6230's, and the 7100g. I then installed my Desktop Manager 4.0 on my laptop, added the policy.bin before I opened it and then connected it to my 6230 and then later to my 7100g. I can install Opera Mini but cannot get it past step 6 before it gives the message that inside and outside the firewall something is being accessed and it is not in the IT policy. You know the message! Everyone has seen it.

Do I have any other options?

John Clark 05-26-2007 01:47 PM

OK...that's the first time you've mentioned the error message you're receiving. Posting that first would have made this easier. Unfortunatly, the remove IT policy procedure will not remove firewall restrictions that were put in place by a BES. The only way to do that is to reconnect to a BES and have a blank policy sent with no restrictions on firewall. Sorry.

stinkyfeet 06-10-2007 10:42 AM

this is the greatest post ever, i recently just got a new blackberry and had to stop using my old one ::cry:: so i was able to get rid of my IT policy on it which i can prolly sell it better or give it away or even use it on my off days

CooCkieXP 06-25-2007 11:42 PM

Will this bin file work on DM 4.2 SP2?

All times are GMT -5. The time now is 10:39 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.