BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   RIM Software (
-   -   Remove IT Policy (

peterjmc 08-12-2008 11:52 AM

Not sure if this was mentioned elsewhere in this thread.

For Vista Users: A copy of the file policy.bin is found in

C:\Users\**username**\AppData\Local\VirtualStore\P rogram Files\Research In Motion\BlackBerry

The ITPolicy has finally been wiped on my 8320 thanks to JL_Cmder "resettofactory" and John Clark

John Clark 08-12-2008 11:30 PM

So, how did the policy.bin file get there? 08-13-2008 02:33 PM

sforget, you should be able to appload the 6750 up to 3.8 or 4.0 device code that you can get from Verizon. My job involves wiping old BlackBerry smartphones from Bell. I had a few 6750's and if I apploaded them to the verizon update everything was a little easier.

jnjewlz 08-13-2008 11:54 PM

Got a mint Sprint BB 8830 on ebay. It worked great for one week when suddenly my GPS no longer connected and I could not get email, etc, etc. I don't use BES and not sure how it suddenly appeared. Somehow a firewall was installed and I got a little red lock next to the firewall that prevented me from disabling it. I read through a million posts and finally was able to blend a few to get that stinking IT policy off my device.

Here is the solution. Hope this helps someone. I pulled an all-nighter to get this down to a science.

*** This is not for use on a company owned device ***
*** This was used on my personal BB running BIS ***

1. Download BB Desktop Software 4.3 (requires a pc restart to complete at the end)
2. Download JL_Cmder, a batch file, compiled by d_fisher, from
3. Download BlackBerry.8830.World.Edition.OS. (others have had success with
*** Search the internet and find it as it's against forum policy to post ***
*** I will not provide you with any information on where to find the OS! ***
*** This software is BETA and you should use it at your own risk! ***
4. Delete Vendor.xml (mine was located in C:\Program Files\Common Files\Research In Motion\AppLoader) and backup the device with BB Desktop Software 4.3 (Cancel the sync if it tries to sync automatically)
5. Install BlackBerry.8830.World.Edition.OS. (must be a version of 4.5)
6. Started BB Desktop Software 4.3, Synced, & prompts you to install updates
7. Click Update Now
8. Do not choos automatic backup the device after the install as it will waste a good hour of your time
9. Device will take a while to come online
10. Shut down BlackBerry Desktop on PC
11. Run JL_Cmder
13. Type in "blackberry"
14. JL_Cmder will reset the device
15. JL_Cmder will show a red screen that says remove the battery
16. Unplug the device from the USB and then pull the battery
17. Wait 60 seconds and reinstall the battery
18. When the device comes online go to Options/Security/General
19. If it says "No Services" do a happy dance 'cause IT settings are gone
20. Got to Options/Security/Firewall and make sure red lock is gone and you can enable and disable the firewall
21. On the PC go to Control Panel/Add Remove Programs and delete BlackBerry.8830.World.Edition.OS.
22. Plug the device to the USB
23. Launch BB Desktop Software 4.3 (mine auto sync'ed with no issues the device)
25. When the device comes online go to Options/Security/General
26. If it says "No Services" do a happy dance 'cause IT settings are STILL gone
27. Got to Options/Security/Firewall and make sure red lock is gone and you can STILL enable and disable the firewall
28. Finally, restore the using the backup we created in Step 3

I took meticulous notes as I was working so you can be sure of that. Hope this post doesn't break any forum rules. Didn't have time to read the entire forum before posting. I am happy to have my device working again.

broecher 08-14-2008 06:09 PM

Stuborn IT Policy
I bought a used 7290 with 4.1 off of eBay. It says it has a blank it policy from John Clark. But it still requires a long password with letters and numbers, the password disable option is missing, and maximum timeout is only 30 minutes. I have followed the usual it policy removal procedure several times with policy.bin files from two different websites and nothing changes. Any suggestions? Thanks so much!

John Clark 08-14-2008 06:15 PM

Not sure why my policy would be requiring a long password or why the timeout would be 30 minutes. Did you try the procedure in the first post of this thread with the policy included there?

broecher 08-14-2008 06:40 PM

I tried the policy.bin from this website:
removeblackberrypolicy com / directions2.htm
It uses a regedit tool.
Then i tried the one on this thread, by manually typing the location into the registry as your directions say, and deleting the policy.bin from the other website from the registry first.
What types of problems do you get from having the enterprise version of desktop manager on your computer? I honestly do not know if i have enterprise or internet version. I have done this successfully on 2 other of the same model phones.
One thing i wondered about was the registry entry in the policy folder right next to your entry that says default - it wonxxx8217;t let me delete it. Is that a problem?

John Clark 08-14-2008 06:44 PM

Are you copying the new policy.bin to the following folder: C:\Program Files\Research In Motion\BlackBerry ?

broecher 08-14-2008 06:58 PM

Yes, I cleaned up after the other websites procedure by deleting the bin file from my c:/ root directory, deleted the entry from the registry. Then I downloaded your bin file put it in the blackberry folder and added it to my registry as the directions say. I looked at the entry and it apeared to have data values as a normal entry does.
Under the general settings page it shows 'policy name: application' and a time stamp from a LONG time ago. does this imply that I did not get your policy loaded? If i go to the owner information page it says it has a blank policy from you. How do you think the owner info page gets edited? would that have been there before i recieved the phone. I dont know what the phone had on it originally, it was password locked and the seller is a dead beat.

John Clark 08-14-2008 07:09 PM

Well, to be honest, I'm not following. You've done so many things to it that I really don't know what you've done.

First, the policy.bin doesn't go in the c:/root directory. So, I'm not sure why you would delete it from the c:/ root directory.

If it shows my name in the owner info, then it should have my policy on it as that gets loaded with the policy included above. I'm at a loss.

jscott1914 08-15-2008 02:06 PM

I tried this last night and it worked!!!........ I then resent the service books and got my personal email icons and everything. Once I connected to my desktop, everything reverted back to how it was prior to following these steps. Im using os on my Pearl. The weirdness of it all is that I can receive personal email on my Pearl through the BIS, but i cannot Send from my Pearl or even Reply to an email. Please dont tell me to re send service books, or wipe handheld again...I've don them both more than enough times.I thought this would do it, but I guess not!!!! I just want to get ALL of my email on my that so wrong!?!?!?!

John Clark 08-15-2008 06:23 PM

So, you were able to remove an IT Policy from your 8100? When you send an email from your Pearl do you have the option to send? Does it error when you send? Please be a little more specific so we can help you. Just stating what NOT to tell you doesn't help.

jscott1914 08-15-2008 09:36 PM

The IT policy did remove and stayed gone. I re sent the service books and got my personal email addded back until I reconnected to my desktop manager. i dont know if the policy came back when I reactivated my work email on BES, or when I restored my backup that I created. Currently my IT policy is active, so I can create, send, and reply to a work email over the BES no problem, but I am only receiving my BIS emails. Can not create, reply, or send an email from one of those account. Hope this clears it up a bit. Did not mean to sound rude...just frustrated. Thanks!

John Clark 08-15-2008 09:51 PM

Um, if you connect to a BES then you can't remove the policy. Are you sure they haven't restricted access to sending BIS emails?

jscott1914 08-17-2008 11:51 AM

I guess that is whats happening. Thanks for the assistance, and the great thread!

Jreneking 08-20-2008 12:58 PM

wow, this is an awesome thread. I read through everything, but i still have questions.

I have an old 8700c from AT&T. I am selling it on eBay, and i want to remove the IT policy that was used on this blackberry with my previous job.

Currently i have an 8130 and my desktop software syncs with that. When i go into the registry, I don't see a folder called policy manager--just manager. Is that the same thing? I don't want to do anything until i know for sure.

Thanks so much in advance.

and yes, it is set up for internet, not for BES.


Jreneking 08-20-2008 01:12 PM nickname should be impatient ;)
i used the "manager" folder and it worked just the same! yay! thanks a bunch.

one last question. when i had this blackberry, it was cingular. now it's at&t. the software still says cingular. will that matter for the buyer?


John Clark 08-20-2008 05:20 PM

Anyone use an 8xxx series device *should* update it to OS 4.5 and use the "resettofactory" method of removing IT policy. That gets rid of it totally.

You can never change the startup splash screen. It will always say what it says.

sumit_5147 08-21-2008 04:42 AM

Is it true that it can restrict HTTP connection also

John Clark 08-22-2008 09:44 AM

1. The generic policy.bin file adds a line that says "research In Motion...blah blah and listed the address and phone number of RIM. Not helpful and caused people to wonder why the owner screen said that.

2. I believe if you add your own owner info, that default info goes away, anyway.

3. I think people like to know that there is an IT policy on the device. The blank IT policy doesn't open the firewall and can leave some items listed in the firewall locked and unuseable.

4. I put my name and this website in the policy so that people who get a BB used and don't know it has a blank policy would know where to come for help. I've had numerous PM's from people who have signed up on this forum only to send me a PM and ask about why it has my name on it in reference to the policy. When I explain they usually are happy and very grateful for the info.

5. There were several blank policies out there and when people come for help this let's me know what version of the policy they have. On the first one I created I missed the "allow split-pipe connections" and that is restricted. I've since changed that and its now set to allow. The first one didn't have my name in it. There is NO other way to tell what kind of blank policy is loaded.

Again, this was added in to be helpful, not for some kind of fame or copywrite issue.

hightoy 09-10-2008 11:11 PM

John Clark,

OS 4.50.55

After wipe the handheld, need or no need pull the battery reboot.

John Clark 09-11-2008 10:47 PM

What kind of wipe? Wipe of the entire OS or just a wipe of the user data?

trishoz 09-14-2008 01:56 AM

I purchased a Curve on Ebay, of course before finding out about IT policies and locked firewalls. I downloaded the policy.bin command to get rid of the IT policy when I had the 4.2 OS but ended up upgrading to the 4.5 and using the JL_Cmder's "resettofactory" command to disable the locked firewall. The only problem is that when I connect to the Desktop Manager I get the red lock and firewall enabled again. I don't know what I am doing wrong....Please help. I have a T-Mobile 8320.

John Clark 09-14-2008 09:40 AM

This is posted in my instructions above (at the bottom, in red.) You need to remove the policy.bin from your PC. Basically do the reverse of Method 2. Otherwise the DM continues to add the blank policy to your device each time you connect to DM.

trishoz 09-15-2008 01:31 AM

Thanks so much. Sorry I didn't catch that and had to ask.

sahli 09-17-2008 03:06 PM

how on heaven do I run this rresettofactory or JL_Comder..... on the blackberry? or on the start menu? no clue where to find this.....

please help

CBR900RR 09-23-2008 07:23 PM

After jl_cmder resettofactory, policy is gone under options>security options>general settings, also I can change firewall from enable to disable, but I still get two locks, one is under memory cleaning, and the second one is under options>bluetooth>device properties, is that normal?

CBR900RR 09-24-2008 07:18 PM

Find another problem, under DM backup and restore, advance, my "save email messege" are greyout and I cannot restore my backup "save messege" into the BB, I already reinstall DM and problem still there.

There is warning message on the bottom says that "I am still under wireless sync or wireless backup and are read only", how do I remove it?

RFHavens 09-24-2008 09:46 PM

This worked!!!!

Originally Posted by TroyDBrown (Post 943772)

Sorry if I missed a post. I have a new 8120 running 4.3.115. I installed BBAlerts and it did not work for my SMS messages. I noticed my FireWall was enabled with a Red lock next to it.

I followed the steps in the first post:
Note: (Added 05/03/2008) If your device has OS 4.3 or higher you can use JL_Cmder's "resettofactory" command to remove ALL IT policy, Firewall restrictions and Application Permission settings. Simply backup the device using Desktop Manager, close Desktop Manager, then run JL_Cmder and execute the "resettofactory" command. The device will wipe, then reboot leaving the OS, 3rd party apps but no data AND, best of all, NO IT policy whatsoever. When you're done, simply restore your backup and you're good to go with no policy or locked firewall.

This removed the lock. Everything now worked fine.

I restored my backup and the FireWall was enabled again with a lock and the original problem again. I am on BIS, phone is new, never been connected to a BES and shows no policies. Any ideas?

I am probably going to just follow the steps and sync and not reload the backup.



Just did this after two days of frustration with the firewall enabled issue. The resttofactory in jl commander is the cats meow. I am on a BB 8330 with and it worked just fine. No battery pulls or anything. Just restored a known good backup and all is back to pre-BES.

Thanks to everyone who has contributed to this fine thread.


Hotchanna 09-25-2008 03:42 PM

I Want To Use My Dam Messengers
I am new to bb forums and i came across your very detailed post. I am not as tech savvy as you are, so maybe the answer to my question was in there some where. anyway I would like to bypass these dam "service is not enabled for this handheld" messages when I try to sign in to AIM, Windows Messenger Live, ICQ, Yahoo and Google Talk.
Desktop Software: 4.6
Carrier: T-Mobile
Optional Services: Unlimited email
Unlimited texting (b/c I have a sidekick on my account)

What I find strange was that I downloaded GoogleTalk from months ago and was using it with abandon. Then suddenly I coudn't sign-in. I know there's a way around it.

Stefanie Nickerson 09-26-2008 03:03 AM

Please help before i go crazy
:xOK i did everything that it said and i still can't make or receive calls. i can do everything else.i don't know what wrong i am mad at this phone


TroyDBrown 09-26-2008 03:05 AM


Originally Posted by Stefanie Nickerson (Post 1115278)
:xOK i did everything that it said and i still can't make or receive calls. i can do everything else.i don't know what wrong i am mad at this phone


You posted in remove IT policy. Are you trying to remove one?

RFHavens 09-29-2008 10:07 AM

CBR, Have you been able to remove the remaining IT Policies? My Bluetooth is fine but the memory cleaning is locked. I did the resettofactory and that did not help the memory lock. From the desktop manager I have the following grayed out:

Certificate Summary Data
Handheld Agent
Saved Email Messages
Time Zones

The look is a bit different because of the later version of DM but mine has Computer Databases on the left side and Device Databases on the right. I am not sure if the warning message on the bottom about wireless sync is there all the time or just when a device has been setup for BES. I really did not pay attention before.

If anyone else has an idea let us know.

Thanks, Robert

CBR900RR 09-29-2008 11:41 PM

I have the Handheld Agent, Saved Email Messages, and Time Zones gray out, I am working with the BBadmin to reslove the problem, I will post back tomorrow if I get problem reslove.


Originally Posted by RFHavens (Post 1118864)
CBR, Have you been able to remove the remaining IT Policies? My Bluetooth is fine but the memory cleaning is locked. I did the resettofactory and that did not help the memory lock. From the desktop manager I have the following grayed out:

Certificate Summary Data
Handheld Agent
Saved Email Messages
Time Zones

The look is a bit different because of the later version of DM but mine has Computer Databases on the left side and Device Databases on the right. I am not sure if the warning message on the bottom about wireless sync is there all the time or just when a device has been setup for BES. I really did not pay attention before.

If anyone else has an idea let us know.

Thanks, Robert

peterkingowusu 11-07-2008 03:24 AM

Worked Like Charm!!
I just flashed and removed the IT Policy on an O2 Blackberry 8300 Curve. Everything is working well now. No password, no firewall. Thanks a lot.

xelx 11-19-2008 03:31 PM

hi guys!

does anybody here can tell me, why my bb doesn't sync to DM through bluetooth after resetting IT Policy? how i can back my previous IT Policy? is it any backup of previous IT Policy on my harddisk??
there's no services in the bluetooth options named DesktopConnectivity and Wireless Bypass which i has before there.
Now i can't connect to internet from my notebook through BT.

I have ITPolicy.exe, but there's no bluetooth options in the .inf file.


bb 7130e \ OS 4.2

LozGemachet 11-30-2008 12:00 PM

I want to add a policy to my Blackberry
I asked this in an other forum with no help; maybe here I'll get an answer

I have a just 3 Blackberry's and I don't need a Enterprise server etc. but I do want to add just one restriction to the phones

so my question is: the same as I'm able to put on a Blank Policy in order to remove any policy's maybe I can add a Policy the same way?
and if yes how to I get it?

All I need is the browser souled be Blocked except for OTA installations this should work.
also if possible other browsers should be blocked as well like opera etc.

if someone can send it to me I'll be very thank full.

Thank You very much

zapcell 12-07-2008 02:03 PM

It Policy removed on sucess !!!

I thanks for this sw uploaded, for friends.


wrhfinancial 12-08-2008 07:42 PM

I asked our IT department a few days ago to take the IT policy off
The guy said I don't know how to do it
Luckily I did not accept his weak response
Thanks for helping me take the IT policy off


jerseyboy 12-12-2008 09:59 PM

Thank you, John Clark; worked like a charm. (y)

mariog7 12-13-2008 02:55 PM

Big thank you!

anya819 12-31-2008 12:12 PM

I have an 8100 Pearl that was previously connected to a BES, apparently with a restrictive IT Policy. I've installed a new OS version 4.5 and followed all the instructions regarding the factory reset. It seemed to work great--all of the settings that seemed to show an IT policy before have disappeared and I've been able to disable the firewall.

However, I still can't get registered on the AT&T network. The host routing table registration isn't working (no entries after registration sent), and while I have some service books and can use the MediaNet internet, I don't have service books for any of the blackberry services. Sending the service books also isn't helping. I've talked with customer service at AT&T and RIM but their magic didn't work--both think it's some sort of IT policy still stuck on the phone. (Not sure if this is a problem, but the setup is only giving me the option to register on a BES, not personal email, and the firewall screen also has the option for blocking BES emails that AT&T says shouldn't be there)

Does anyone have suggestions about what to do next? Where could I find this policy that might be there? Or, do you have any other thoughts about what might be wrong?

Many thanks to everyone for this thread--it's been very helpful!

John Clark 12-31-2008 12:24 PM

If you're able to disable the firewall then there is NO policy left on the device.

This sounds like an issue with your BlackBerry Data Plan. It sounds like it hasn't been provisioned properly yet. Make sure you've subscribed to a BlackBerry Data Plan with ATT.

anya819 12-31-2008 02:21 PM

Thanks for the suggestion. I just spoke with AT&T again to suggest that it's a provisioning issue. They changed the data plan on the account, but it didn't seem to help. They had me switch SIM cards with my husband's blackberry and change up the service in the web client.

I was able to take my SIM card out, change the web client, and make the blackberry service work on my husband's 7130 device. However, I wasn't able to make my husband's blackberry service work on the 8100 device. On the pearl, the letters in the top corner change to a lower case "edge" but won't change to the uppercase "EDGE". The Media net internet icon works on the pearl, but the blackberry push won't work with either SIM card.

Does that make this some other sort of device issue aside from an IT policy problem? Any other thoughts on what might be wrong?

John Clark 12-31-2008 02:37 PM

So, for whatever reason the device is not connecting to the RIM data center. Where did you get the BB? Did you get it used? eBay or something? It's possible the device was stolen and the pin blocked by RIM? I would contact the seller if that's the case.

John Clark 12-31-2008 02:41 PM

Under Options >Mobile Network is "Data Services" set to On?

anya819 12-31-2008 02:44 PM

Yes, I bought it from a seller on eBay who said it was "new, never opened", which is obviously not the case since it's been connected to a BES in the past. I've contacted him to see what's up.

AT&T tech support has passed me to RIM a few times and they never said anything about the IMEI being stolen or blocked. I"ll check with them again since the case the still open.

Thanks again for all the good thoughts and suggestions!

John Clark 12-31-2008 02:49 PM

Yes, since it's definitely not "new, never opened" I'd probably see if you can return it.

foursight 01-15-2009 12:13 PM

I have an 8310 running I used JL_cmdr and the "resettofactory" command then wiped the device to remove the IT policy but it remains on. I didn't delete the policy.bin or make any registry changes on my PC because I didn't think those steps applied to my software version, should I do that?

John Clark 01-15-2009 07:18 PM

Wirelessly posted (BB 11020)

If you've NEVER used method 2 then resettofactory is all you need. If you've downloaded and applied the policy.bin in method 2 in the past then you'll need to remove it as it will apply to every BB you plug into it.

megdy 01-17-2009 02:41 PM

THANK YOU for this info

wrhfinancial 01-17-2009 04:26 PM

I did this on my 8800
Will it also work with the Bold



twelvike 01-18-2009 11:57 AM

cool, thx John,
The first methood perfectly work for me.

bob64064 01-18-2009 07:23 PM

I'm about to give up
1 Attachment(s)
Purchased an 8703g from a reputable seller on ebay. The phone was set to lock after TWO minutes and password cannot be disabled. After a two hour discussion with Verizon and Blackberry we discovered the problem discussed here.

The seller referred me to here to get rid of the IT restrictions.

I followed your instructions in the first post to the letter. However now all I can get from the phone is a blank screen with an icon in the middle....large circle with a diagonal bar through it and a rectangle in the middle, with "507" beneath the circle. Screenshot attached.

What the heck is going on? Any ideas?



John Clark 01-18-2009 07:29 PM

You need to reload the OS to the device. 507 simply means the device is ready to have the OS reloaded.

Just follow the instructions here:

bob64064 01-19-2009 10:37 AM

Thanks John
I loaded the new os. ran the IT deletion software again. (How long should this procedure take? It only took a few seconds here. So I downloaded the software again, reinstalled it, ran it again. Same result) Removed the battery. No apparent wipe occurred. Did a manual wipe from the security screen. No joy in mudville. There seems to be no change at all in the settings and I still have no access to changing the password or security timeout (which is still set at 2 min). Now there is a little red dot or maybe a lock (too small to tell) beside each of those options. And the IT policy name and last update are still on the security screen.

Can you help????? please!



John Clark 01-19-2009 12:29 PM

Wirelessly posted (BB 11020)

This works on every BB. You are doing something wrong. Since you're working with an 8703 you should be using "method 2". There should be no reason to reload the OS during this procedure. Please follow the instructions exactly as outlined.

bob64064 01-19-2009 01:17 PM

Thanks again John
I thought I did follow the instructions. I thought it said if you're using an 8XXX BB then method 1 was to be used. But I will go back and retry with method 2.

I really do appreciate your assistance. I'm just frustrated with not getting any help from the seller. And I spent a ton of time yesterday trying to get it to work. Hopefully method 2 will work, as I'm sure it will.

Thank you


John Clark 01-19-2009 01:28 PM

It says you *should* use method 1 if you have OS 4.3 or higher. I'm assuming your 8703e has 4.2 or older. The "resettofactory" in JL_Cmder doesn't work on OS 4.2 and older. It sounds like you did the "wipe" in JL_Cmder and that removes the OS from the device but doesn't touch the IT policy. If/when OS 4.5 comes out for the 8703 then you can load OS 4.5 and then use the resettofactory command with JL_Cmder.

bob64064 01-19-2009 02:38 PM

Thanks John. Using the second method worked like a charm. And you're correct about the sequence of events which erased the o/s. I looked, but didn't find, the release number/edition for the o/s on the BB. So... when I downloaded the new o/s, I assumed (and yes, i know)..etc, etc. Wrong assumption apparently. All is now ok, other than the firewall. But I can live with that for the time being.

Thanks again


John Clark 01-19-2009 03:20 PM

When one of the carriers releases 4.5 for the 8703 then you can load it to the device and use method 1 to remove it completely and have the firewall open, if desired.

I recommend going back now and reversing the steps of method 2 to remove the policy.bin file from the computer. Otherwise every subsequent device you plug in to the Desktop Manager will get the blank IT policy and you don't want that.

angryuser7 01-23-2009 02:27 PM


Loading the blank IT Policy will let you set a 3 character password, but wont let you unlock with the same correct password.

See this thread:

John Clark 01-23-2009 03:12 PM

That is likely a specific OS issue, not an IT policy issue. Upgrade your OS.

pnages 02-14-2009 12:46 PM

[QUOTE=John Clark;484042]WooHoo!!! Never gave up! Gre

John...I have 8310 that i inherited from my company. I am trying to remove "it policy". is there a way to do this through my MAc?

John Clark 02-14-2009 12:47 PM


JSanders 02-14-2009 12:52 PM

If the Mac user runs Parallels or Bootcamp, with Windows, can't they run JLCmder?

jsconyers 02-14-2009 01:01 PM


Originally Posted by John Clark (Post 484042)
WooHoo!!! Never gave up! Gre

John...I have 8310 that i inherited from my company. I am trying to remove "it policy". is there a way to do this through my MAc?

You may want to read the first post. This in particular.

Important: If you're still connected to a company BES, and simply want to install the latest and greatest third party application I would not recommend this approach. Talk to your BES administrators and ask them to grant you the appropriate rights. There are two problems in using this guide to bypass your company's security policy. First, whenever you reconnect to the company server, your security settings will revert back to how they were. Second, and perhaps more importantly, you run the risk of getting fired.

John Clark 02-14-2009 01:17 PM


Originally Posted by JSanders (Post 1285324)
If the Mac user runs Parallels or Bootcamp, with Windows, can't they run JLCmder?


lamlamz 03-03-2009 07:13 PM

Removing IT Policy Options
I have complied a short tutorial on how to remove IT Policy using BES.
This article will be helpful to both user and IT Admin.

I could not post link but check out my signature.:razz:


Lurka 03-22-2009 06:35 PM

Allow outgoing calls when locked?
I successfully wiped my old 7100, installed the latest OS and forced the clean IT policy on it, but now I notice that it no longer has the option "allow outgoing calls while locked" listed under the security general settings.

Is it possible to add that feature to the policy.bin file?

Thank you 03-23-2009 12:06 PM

Thanks John.

I used your policy.bin yesterday on a 7130e that I had bought thru Craigslist.
When bought I wasn't able to connect to DM, it would ask for the password and that was as far as I could go.

Now I was able to download OS 4.2 and have the BB up to date.

Once again, Thanks


ddasilva99 03-29-2009 01:13 PM

Is there a way to remove the ITPolicy from BB 8330 without de-registering the device on BES?

John Clark 03-29-2009 01:17 PM

Um, NO. Please read the first post. This procedure is NOT for those who are on a BES who want to "get around" the IT policy. There is NO way to have a BB on a BES without that BES's IT policy. If you remove it you are removed from the BES. The policy will be replaced if you reconnect to the BES.

This procedure is for those who are removing their device from the BES or got a device used with a leftover IT policy.

jsconyers 03-29-2009 01:18 PM

No. There is no way of removing the IT policy from ANY device without breaking your connection to the BES. I would not recommend trying to do so. It could get you into a lot of trouble with your employer and will be pointless in the end as once you're reactivated on the BES the policy will be pushed back to your device.

Also, could you please update your profile to reflect your current device/carrier? It will be helpful for future questions :smile:

XtrlRulz 04-01-2009 07:41 PM

It works like a charm!!! Thanks!!!

leggins 04-02-2009 10:42 AM

It Policy
Hi I got a Blackberry 8800 with BES. How can I get rid of the IT Policy. I already tried "Settofactorysetting" with JL_Cmder, upgraded to O 4.5.

No luck. I am not very technical savvy. And also happy to pay company that is doing the job for me.

Thanks for any help.

jsconyers 04-02-2009 10:44 AM

Welcome to the forums.

Are you currently on a BES? Do you receive work email on your device? If so, this is NOT what you want to be doing.

diptrkg 04-06-2009 07:48 AM

Installed the blank it policy and was able to get rid of the password to enter on my 7520, how can I get my bluetooth to work now? Does not pick up devices. Thanks

willrivera 04-24-2009 03:20 PM

Ok we have a empty policy set on our BES, usually we have the employees moved to that policy when they are leaving the company and then we remotly wipe their device to delete all the company information. we are having issues in where the employees change their data plan to personal and now they are no conecting to the bes so we are unable to remove the policies until they call the provider and get the bes data package again. is it posible to push an unlocked policy to a device with the wrong data or no data at all trhu desktop manager? and then wipe it. or policies are only pushed OTA?


John Clark 04-24-2009 03:42 PM

Wirelessly posted (BB 11020)

Yes, I believe that is possible.

willrivera 04-28-2009 01:34 PM

Ok so this is what i got after testing pushing policies to a device with not data or service at work, so i installed desktop manager 4.2 with the redirector (exchange) option and that did not work, but i removed the desktop manager and then reinstall using the personal option and it worked perfectly. so i am not sure what is going on but it work fine with th bis option and all of the changes on the bes applied succefuly to the device.(y)

clyde101 05-08-2009 07:28 PM

Bb 8310
I purchased my work BB and was laid off a few months later. I have followed the instructions and haven't had any luck downloading the policy.bin. It comes as a blank 14 kb file.

ANy suggestions because i am almost ready to hammer this THING after 3 days of messing with it.

Thanks in advance...

jsconyers 05-08-2009 07:29 PM

Welcome to the forums.

What OS is on the device? Options > About.

John Clark 05-08-2009 07:36 PM

With an 8310 there is no need to download the policy.bin.

Upgrade your OS to 4.5 (if it isn't already) and then follow the instructions in Method 1.

clyde101 05-08-2009 10:21 PM


Originally Posted by jsconyers (Post 1377727)
Welcome to the forums.

What OS is on the device? Options > About. (Platform

Is that what you're looking for in terms of OS system? Sorry for my lack of knowledge..

jsconyers 05-08-2009 10:31 PM

Yep, that's it. Follow the steps John posted above.

JL_Cmder resettofactory.

clyde101 05-08-2009 10:32 PM

[QUOTE=John Clark;1377731]With an 8310 there is no need to download the policy.bin.

Upgrade your OS to 4.5 (if it isn't already) and then follow the instructions in

Sorry John, but I didn't understand JL_Cmder. Is that on the BB, if so where is it and how would I access it?

I had a tech at AT&T reset it to factory settings (I think) but I can't deselect the "Enable" function; it's still locked. I even did a wipe form the "security" section, and selected "include all third party software" and it is still there, so I am at a loss on what to do next.

If you have any 8xxx device the best method for removing IT policy is to update it to OS 4.3 or higher (if possible) and you can use JL_Cmder's "resettofactory" command to remove ALL IT policy, Firewall restrictions and Application Permission settings. After you've upgraded to OS 4.3 or higher, simply backup the device using Desktop Manager, close Desktop Manager, then run JL_Cmder and execute the "resettofactory" command. The device will do a security wipe of the device; (meaning wipe your data but leave the OS, DO NOT use the "Wipe" command in JL_Cmder) then reboot leaving the OS, 3rd party apps but no data AND, best of all, NO IT policy whatsoever. When you're done, simply restore your backup and you're good to go with no policy or locked firewall. You can downgrade back to the old OS if you desire, too.

jsconyers 05-08-2009 10:37 PM

You need to download and install JL_Cmder on your PC

clyde101 05-08-2009 11:50 PM

Thanks for that info.

OK, I did that and read through the posts regarding the temp "flash" and subsequent disapearence of JL_Cmder. I turned off my firewall and ran it with the same results. Any suggestions?

clyde101 05-09-2009 12:00 AM

HOLY COW!!!!!!!!!!!!!!! It's fixed!!!!!

I certainly APPRECIATE all of time and expertise that you all have devoted to this site. I will research all areas of the site and try to contribute something to repay your help.

Thanks again...

jsconyers 05-09-2009 12:02 AM

Good deal (y). Glad that you got it working!

clyde101 05-09-2009 12:07 AM

FYI for others: I right clicked JL_Comder and selected "Run as Administrator" which seemed to work. Best of luck.

ghaase4 05-14-2009 02:37 PM

After using the policy.bin, I did get rid of my old IT policy. But I still can't use bluetooth to sync. According to BB, its because:
"Note: If the BlackBerry smartphone has an IT policy that has removed the desktop connectivity service (located in the Bluetooth options), the BlackBerry smartphone will be able to pair, but it will not be located by BlackBerry Desktop Manager."

So there's that. And Verizon visual voice mail doesn't work. Something about the firewall settings.

jsconyers 05-14-2009 02:40 PM

Don't use the policy.bin method. Use the ResetToFactory option in JL_Cmder.

John Clark 05-14-2009 03:44 PM

Wirelessly posted (BB 11020)

That's why it says to ONLY use Method 2 on devices that can't be upgraded to OS 4.3 or higher.

UnderNewbie 05-17-2009 11:40 AM

I got problem of a small red lock appearing at Firewall settings
Thanks for great method.
I am restoring all now!

John Clark 05-17-2009 11:52 AM

Wirelessly posted (BB 11020)

You still have this problem or this was the problem before removing the policy?

oasissux 06-09-2009 11:30 PM

I've been trying to use jl_cmdr to reset my IT policy, but I can't get the program to load. It flashes on the screen, then disappears. I've tried 20 times, using "run as admin". I'm running Vista. What am I missing? I tried using the FAQ instructions "what to do next if jl_cmdr will not connect and wipe". How do I use the apploader to resettofactory once the apploader loads?? The only options it gives me is "Add".

oasissux 06-10-2009 12:00 AM

Alright, I managed to get JL_cmder to run, but when I choose resettofactory, the next screen says

"error: unable to to open port

command completed!"

I never get the 507 screen. I tried the next faq, no luck. Anyone know what I'm talking about??

oasissux 06-10-2009 04:54 PM

I was surfing around forums and I came across a post that suggested just using loader.exe/resettofactory from the command line to remove the IT Policy and it worked like a charm.

All times are GMT -5. The time now is 07:40 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.