BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/index.php)
-   BES Admin Corner (http://www.blackberryforums.com/forumdisplay.php?f=21)
-   -   BPS: Enterprise activation fails but BB connects momentarilly (http://www.blackberryforums.com/showthread.php?t=214501)

coldfeet 12-21-2009 11:01 PM

BPS: Enterprise activation fails but BB connects momentarilly
 
BPS v4.1.4.17
SBS 2003 sp2

Hi,
This is my first setup & I'm pulling my hair out at this stage so I'm hoping someone can give me a little inspiration.

Problem:
I've added a BB to the Blackberry Manager, setup the default IT policy and set the activation pwd. When I try enterprise activation on BB it hangs and comes back saying server unavilable, please contact system admin, when I check the BB Manager I can see that it connected for a moment, received the pin but no messages were forwarded.

Setup:
1. I created a Besadmin account on the server and gave it all the permissions as requested on the BB documentation.
2. Installed the BB Manager & used the created Besadmin account.
3. Started the iMapi service
4. Added the CAL licence and the new phone.
5. Exchange & BB Manager are on the same server in the same domain

Steps taken:
1. Checked with Optus and the phones are correctly provisoned with the correct service books.
2. Recreated the besadmin account, double and triple checked the permissions.
3. Deleted & readded the phone, setup sniffer on the network, I can see 2way communication between my server and the BB ip address but then the connection is terminated. I see a check sum error between traffic form my server and BB
4. Checked the BB Support page and being through all these steps, for problem KB13458 ( sorry can't post urls)

I'm hoping its something small I'm missing but I just can't see what it is. Give me an early Xmas present and help point me in the right direction

penguin3107 12-22-2009 05:43 AM

You probably have the wrong data plan provisioned on the mobile account.
Make sure it's the ENTERPRISE BlackBerry plan.

coldfeet 12-22-2009 05:11 PM

I've checked with Optus, originally it was setup with the wrong plan and didn't connect.

I got it changed to the correct plan but it still dosent work for me.

nobody7290 12-22-2009 05:35 PM

If the provisioning is changed, it may take hours until this is really done - have you asked when you can expect that the change of service is done ?
also: you should do a battery pull, otherwise the phone will not get the neccessary information.

coldfeet 12-22-2009 05:42 PM

The provisioning was changed last week and I have powered off the phone, removed the battery, replaced and powered on

nobody7290 12-22-2009 08:03 PM

If you shutdown the BES/disable all services,
Then, try an enterprise activation from a BB of your choice with a valid email address and random password:
Will an email with an attachment "etp.dat" arrive in the users mailbox within a minute or not ?

if not:
Problem with Email system, Antispam, Firewall or similar

coldfeet 12-22-2009 09:53 PM

I rebooted the whole server to be on the safe side.

I setup a new user with the default it policy, the user received an email with their pwd but no attachment etp.dat, is this meant to arrive as a seperate email or a part of the pwd email.

coldfeet 12-22-2009 10:12 PM

The email from *.blackberry.net came through to the users email after 5mins with the attachment etp.dat but nothing has happened on the BB device.

Does it matter setting up the enterprise activation through wireless or desktop manager for the BPS server?

nobody7290 12-23-2009 03:37 AM

I think 5 minutes is too late for a sucessful wireless activation. Maybe if your system uses a delaying feature to reduce spam, you could tweak your antispam system to immediately accept all mail from *.blackberry.net

Wireless activation AFAIK works like this:
1. you set a password
2. The user enters the email and password on the device
3. the BB sends the activation message to rim
4. rim sends an activation mail to the users email
5. The BES picks up the email and checks it against the password
6. if the password matches, the BES begins communication with the device via the relay of rim's servers and does the activation

But: The device does not wait endlessly for the activation. After X Minutes it aborts the activation.
If the mail arrives later, the Server will try to communicate with the BB, but then, activation is already aborted.

If your antispam software is able to learn automatically, you would be sucessful at the next try, but if not, it will not work.
--

Yes, if you make the activation with USB, this should work immediately, if everything else is setup ok.


All times are GMT -5. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.