BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/index.php)
-   WiFi HotZone (http://www.blackberryforums.com/forumdisplay.php?f=103)
-   -   Shall I throw out this piece of junk [ 8320 wifi issues] (http://www.blackberryforums.com/showthread.php?t=211298)

blackberrywifi 11-20-2009 08:16 PM

Shall I throw out this piece of junk [ 8320 wifi issues]
 
Please excuse my language and frustration but my Blackberry experience has not been that great recently. I bought this soft unlocked phone from one of the stores on ebay and have not been able to get wifi working. I have gone over several forums relating to similiar issues.

The issue
BB seems to detect all networks but is not able to connect to them and mostly results in "Association Failed". BB can see the gateway mac

Things I have tried
1) Make the network "Open"
2) Tried WEP encyption
3) Ensured MAC filtering is disabled
4) Enabled MAC filtering to see if the bb shows in disable mac addresses list
5) Tried Different Channels
6) Removed SIM -> Reloaded BB -> Even without SIM it detects but doesnot associate
7) Tried with SIM on which there is BES DATA Plan (No Luck)
8) Upgraded OS
9) Manually Configured the IP Addresses, Subnet mask, Gateway and DNS but no luck
10) Ensured the two service books are there, Ensured the Browser is "HotSpot Borwser"


Tried Nokia phone and it connected in the first shot over network. No hiccups and no annoyance.

I am not sure what other things i should try to make it working. The only thing i could think of now is to get a sniffer and see what and where the issue is. I was hoping OS upgrade would fix the issue but that didnot help at all. Should setting up a wifi be such a pain? It seems lots and lots of people are having similar issues with 8120, 8320, 8820 and so on....

any ideas, leads, hints, comments, suggestion would be much appreciated

________________________________
Blackberry 8320
smartphone (EDGE, Wi-Fi)
v4.5.0.174 (Platform 2.7.0.105)
*********
********
WLAN Version: 2.3.0.82
________________________________

flash24 11-20-2009 10:31 PM

Have you tried connecting on a different router like Starbucks or something? If it didn't connect then you might have a faulty device. I don't know what else I can tell you, it seems like you tried pretty much everything.

MidnightDraven 11-22-2009 08:37 AM

Ever reboot the router?

NJBlackBerry 11-22-2009 09:12 AM

Any possibility that this eBay purchased BlackBerry was defective?

Been known to happy. Contact the seller.

JSanders 11-22-2009 09:24 AM

What do the indicators at Manage Connections say, do you get a white dash next to WiFi setting, a red bar, or what?

Do you have a BlackBerry Data Plan on the account?

blackberrywifi 11-24-2009 10:09 PM

I have tried pretty much every thing except testing it at starbucks. I am thinking the wifi on this device is bad.

I will update you all on this once I test it out tomorrow ;)

JSanders 11-24-2009 11:22 PM

but no answers to the questions...


All times are GMT -5. The time now is 02:51 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.