BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   RIM Software (
-   -   Remove IT Policy (

Bozo2007 07-01-2008 04:15 PM

Ok I will try this once more. There is no policy.bin within 200 miles of my house. hahahaha I give up. 2 weeks at this and still no solution. The fact there is a policy.bin on my bb indicates of course its picking it up from somewhere. Must be coming from mars but i dont know how my house is covered in tin foil.

John Clark 07-01-2008 04:18 PM

It's there...somewhere. I've done this before and removing the policy.bin from where I placed it and editing the registry to the way it was before has always worked and I never put a policy on accidentally.

Bozo2007 07-01-2008 05:13 PM

I did it!! Firewall unlocked and bluetooth workie!!
First off I would like to thank John for putting up with me. Here is what happened.

I decided to do a search for John Clark on my computer. A little file poped up called untiltled.inf. Low and behold this little file (John would know better then I) is the cfg file for policy.bin. I was playing around with the itpolicy exe and it created this file. So no matter how many times I deleted policy.bin itself somehow this untilted.inf was creating and adding to my BB. I deleted it. Checked my computer again and there it was....policy.bin sitting in an obscure hidden directory. One thing I should point out John in case it comes up again. This was vista and a lot of strange things happen with vista. I will source this out more and find out exactly why this was happening so no one else has to go through this.

John Clark 07-01-2008 05:18 PM

At the risk of sounding condescending (because I'm not) I wouldn't mess around with itpolicy.exe unless you know what you are doing. Someone posted it here and thats fine but this is what can happen.

A simple backup, resettofactory, and restore was all that was needed.

Bozo2007 07-01-2008 05:29 PM

The problems started with Unite software. By the time you figure out whats going on and reading the mis information as well as your good information you get frustrated. Then you start to try anything to get it to work. Vista doesnt help. Anyways....thanks John....the good news is I learned A LOT!!! ;-)

John Clark 07-01-2008 05:31 PM

That's why I mention the resettofactory method for OS 4.3 and higher first. You shouldn't have needed to read any further.

Glad you found it.

raymond11 07-02-2008 04:16 AM

Again, trouble started with unite! and I was going crazy. your post was great and now I feel like a new guy with a new phone. Unite is fine but it'll be for the bold or something else with wifi.

I con't thank you enough

nemogamo 07-07-2008 10:10 PM

Dear Jhon,
i have 8707g with Firewall anabled and its locked
its 4.2 OS version !
i follow exactly with your direction
but still can not getting done...
the firewall still enabled & locked
when i press the option-status & type BUYR
under IMEI :
Data Usage IT Policy Enabled
Voice Usage IT Policy Enabled

Is there any upgrade 8707 to 4.3 OS ?

John Clark 07-07-2008 10:15 PM

There is no OS 4.3 for the 8707.

The second method should work. However, you cannot unlock the firewall using the second method. The second method just puts a blank IT policy on the device so it will show that there's a policy.

nemogamo 07-07-2008 10:21 PM

Too bad..

I try the second method, but no luck
Still have an IT Policy Enabled.. :-(

John Clark 07-07-2008 10:28 PM

It will ALWAYS have an IT policy on it. There is no removing it COMPLETELY unless the device has 4.3 or higher. The best that can be done is the blank IT policy (method number 2) and that still leaves a policy, just the least restrictive available. The second method WILL NOT unlock the firewall. It can't be done unless the device has OS 4.3. I hope this is clear.

nemogamo 07-07-2008 10:38 PM

Its clear John, Thanks
now i have to look another way $$$

John Clark 07-07-2008 10:39 PM

Is the firewall locked to where you can't use it?

nemogamo 07-07-2008 11:38 PM

Opera mini can't install due to the firewall restrict

John Clark 07-07-2008 11:42 PM

What error message do you receive?

nemogamo 07-08-2008 09:54 PM

sorry for late reply, after several install attempt
finally the opera mini works...
but firewall still enabled and locked ;-(

lmq1985 07-11-2008 12:25 AM

question:what is IT policy ,and what will happen to my BB after remove IT policy

BigPete74 07-24-2008 10:19 AM

This is a great thread but I am having some issues. I would also like to curse BlackBerry Unite!

Ok, so I installed BlackBerry Unite to give it a try. I uninstalled it and, of course, I am not having the IT policy and Firewall enabled issue.

I have used JL Cmder to wipe my 8330 (Verizon). Once I did that the Unite IT policy no longer shows up Options -> General Security settings. However, typing in BUYR at the status screen still shows IT policy enabled. According to this thread, that's normal and you will never get that to say disabled. Is this correct?

Secondly, I am having issues with the Firewall. The Firewall shows enabled right now. Right after I do the JL Cmder restoretofactory, it shows as disabled. It seems to me that only after I enable my network connections does it become enabled. Is there a service book I can remove? If this is the problem how do I prevent it from being pushed to my BlackBerry?

How do I disable the firewall completely?

And before you guys ask. This is a brand new phone purchased from Verizon. It is not used and has never been used with BES. I am running 4.3 ( on it.

sforget 08-10-2008 11:39 AM

Bell 6750 : unable to remove policy
Hi there! I was able to remove IT policies off 8700's from rogers, 7100's from nextel, 7250's from bell, 7290's from rogers and even 7750's from seems somehow that it doesn't work with 6750's from bell since they use a 12pin com-type serial connection instead of USB. I tried downloading the most recent versions of blackberry desktop and device softwares and followed the same instructions as with the other models without results. I tried reinstalling the firmware a couple of times but it didn't work......I also tried wiping the device from the security menu, but it seems that it's not an available feature on this model. I'm desperately trying to find a workaround since I have at least 50 units that need to be wiped clean........Can anyone help me please?

John Clark 08-10-2008 11:43 AM

Wirelessly posted (BB 11020)

No idea. I've never had one.

All times are GMT -5. The time now is 01:36 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.