BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/index.php)
-   RIM Software (http://www.blackberryforums.com/forumdisplay.php?f=13)
-   -   Remove IT Policy (http://www.blackberryforums.com/showthread.php?t=67224)

John Clark 02-29-2008 10:25 PM

Do you have Desktop Manager installed?

dannyboyblue 03-01-2008 12:27 PM

yes I have desktop manager installed and it's set to internet service and not enterprise service. Any ideas?

Danny

ahtian928 03-29-2008 11:49 PM

mark for reference!

neddy knacker 04-06-2008 09:25 AM

How come the blackberry website wont let me download the desktop manager??? It just say access denied WTF???

neddy knacker 04-07-2008 09:34 AM

Right I've got the software downloaded just gotta try and remove the IT Policy.

neddy knacker 04-07-2008 10:57 AM

Thank you so so so so so so much :smile:

Hilroyy 04-12-2008 12:15 PM

Would this policy affect my bluetooth headset connection??
 
I have noticed ever since I applied the removal of the IT Policy on my BB 8300 my bluetooth connection to my bluetooth headset hasn't been the same. The range has dropped to about 3 feet before it becomes to staticy to talk. Any thoughts on this??

a1tone 04-15-2008 09:32 AM

Problems with BB connection
 
Hi

I am trying to remove the IT policy from my BB that I purchased off Ebay.

I have downlaoded all the software onto my PC. When I conntect the BB to the PC via USB, the PC sees the BB and installs the driver, but when I open Desktop Manager, it show that the BB is disconneted. When I go into option's and look at serial settings and detect, it doesn't detect my BB.

Can anyone help me please!

Anthony

I have sorted this problem, I installed it on my Vista PC and it lets me choose connection type USB and it works fine and I have also removed the IT Policy using the instructions provided.

Thanks

BeefyBeefo 04-23-2008 12:56 AM

First of all, I just joined the site. I've been lurking for a couple days now ever since I got my BB 8830 from VZW, and this site has a TON of information.

I had to make this my first post because this just helped me out tremendously. The BB I got had an IT Policy on it and these steps worked great and are very easy to follow. I have to go get my contacts transfered from my old phone again, but that's not a big deal because I get free phonebook transfers from VZW (won't have to worry about that anymore now that I can backup my BB without the IT Policy!). So, I just wanted to say thank you very much!

-Jeff-

ajfromca 04-24-2008 03:49 PM

8100 Pearl
 
TKS John it worked
I had bought a BB 8100 on eBay that had a password lock on it and did give to option to remove only change.

I was following the steps, and got to the part to copy the .bin file (my pearl was synced the entire time for a backup) when I disconected it and went to wipe it and the password lock was gone (i.e. the little red star at the side of the change password box). I did not need to do the regedit part, so those who are afraid of this you might not need to do it. and lauragal is right the file path of the registry you are using cannot affect the computer unless you do something really wrong. Remember system restore it was made for that reason.

rowlandg 04-25-2008 09:44 AM

What happens to policies when you do a restore?
 
Hi,
I have a Blackberry that is being replaced by T-Mobile. I consult for a living and being new to BB and a little naive I connected mine to the client's BES. Well as you might have guessed mine ended up with all the restrictions they impose on employees. Now I've left the client for bigger spaces.

The broken-soon-to-be-replaced device is backed up and ready for the new replacement device. So if I restore the backup will I also restore the !@#$!@# problem of the policy that doesn't seem to go away?

I hate to loose my contacts and all that but I sure don't want to re-introduce this to a brand new device.

Thanks

John Clark 04-25-2008 09:53 AM

No, IT policy is not backed up or restored so you're fine. Many people apply the blank policy with the above instructions but don't remove it when they're done. That's when the policy gets applied to the next BB connected, as well.

Mobile Experts 05-03-2008 08:59 AM

Thanks for ur soulation i done my vodafone 8800...

LD555 05-05-2008 02:38 AM

Good Stuff John ... Thank you very much.
So after removing the policy ... am I on BIS and no longer BES anymore?

John Clark 05-05-2008 10:28 AM

That is correct. However, if you are supposed to be on a BES with your company you may be in deep **** for removing the policy. If it's just leftover and you no longer have to be on that BES with that device then, yeah, you are no longer on BES.

LD555 05-05-2008 02:58 PM

John, Will the old Policy come back if I restore my BB using the back-up. How do I get back on BES without contacting IT? It was very cool the things I can do without the Policy and restrictions. But my job is definitely more important ... :-D ... Thanks.

John Clark 05-05-2008 04:40 PM

Did you not read the following quote from the first post?

Quote:

Originally Posted by John Clark
...Important: If you're still connected to a company BES, and simply want to install the latest and greatest third party application I would not recommend this approach. Talk to your BES administrators and ask them to grant you the appropriate rights. There are two problems in using this guide to bypass your company's security policy. First, whenever you reconnect to the company server, your security settings will revert back to how they were. Second, and perhaps more importantly, you run the risk of getting fired.

You need to connect your device to Desktop Manager on your work computer connected to your work email. If Desktop manager isn't setup properly to acquire an online connection with your email profile then you're going to have to contact IT to reactivate on the BES.

It's posted in this thread many times about doing this when you are still connected to a BES. it's a BAD idea.

LD555 05-05-2008 05:19 PM

Thanks John ... Live and Learn. Now I will have to buy the Admin some Krispy Kreme to put me back on BES. haha.

John Clark 05-05-2008 05:29 PM

Just tell them you wiped the device trying to solve a problem. Issuing a BES activation password usually isn't a big deal.

cmpugh 05-09-2008 05:31 AM

IT Policy IS backed up and restored... I just found that out the hard way.

Went from 8830 to 8330... As info to everyone...

BeefyBeefo 05-12-2008 05:25 PM

Hey John, I apologize if this has been asked before. I searched this thread and didn't come up with anything. As I mentioned above a few weeks ago, this process helped me out tremendously with my used BB. I know in the first post in this thread you say that you cannot use BT keyboards after completing this process and that doesn't bother me at all. My question is, can I use a BT GPS Puck after implementing the Blank IT Policy? I'm interested in getting the Freedom keychain unit. I appreciate your time, thanks!

-Jeff-

John Clark 05-12-2008 05:38 PM

Wirelessly posted (BB 11020)

Yes, you'll be able to use a BT puck. Good luck!

BeefyBeefo 05-12-2008 05:39 PM

Now that's what I wanted to hear :) Thanks a lot, John.

-Jeff-

Chitown021 05-18-2008 09:06 AM

Thanks for creating this thread John. I just became a BB user thanks to my dad (he game me his old 8700g when he upgraded) and I'm learning as I go. The device he gave me had a policy locking the password to enabled and the lockout to happen every 2 minutes. I haven't used your procedure yet but I have it bookmarked in case dad has any issues getting the IT dept to send a blank policy.

EDIT: John, I used this process and it worked like a charm! I checked and can now disable the password, change the lockout timer from that annoying 2 min, and despite your warning in the OP it DID unlock the bluetooth keyboard option (it lets me change it to ALLOW). The only setting I noticed that was still locked is FIREWALL. The Blackberry will not let me change it from ENABLE.

THANK YOU!!!!

TroyDBrown 05-25-2008 08:40 PM

John,

Sorry if I missed a post. I have a new 8120 running 4.3.115. I installed BBAlerts and it did not work for my SMS messages. I noticed my FireWall was enabled with a Red lock next to it.

I followed the steps in the first post:
Note: (Added 05/03/2008) If your device has OS 4.3 or higher you can use JL_Cmder's "resettofactory" command to remove ALL IT policy, Firewall restrictions and Application Permission settings. Simply backup the device using Desktop Manager, close Desktop Manager, then run JL_Cmder and execute the "resettofactory" command. The device will wipe, then reboot leaving the OS, 3rd party apps but no data AND, best of all, NO IT policy whatsoever. When you're done, simply restore your backup and you're good to go with no policy or locked firewall.

This removed the lock. Everything now worked fine.

I restored my backup and the FireWall was enabled again with a lock and the original problem again. I am on BIS, phone is new, never been connected to a BES and shows no policies. Any ideas?

I am probably going to just follow the steps and sync and not reload the backup.

Thanks,

Troy

John Clark 05-25-2008 09:12 PM

Have you EVER used the other Remove IT Policy method? Is it possible the old policy.bin file is still on your computer from that procedure?

TroyDBrown 05-25-2008 09:21 PM

Quote:

Originally Posted by John Clark (Post 943798)
Have you EVER used the other Remove IT Policy method? Is it possible the old policy.bin file is still on your computer from that procedure?

Yes I have. My computer gets many firends BlackBerry's attached to it for various reasons. I did remove an IT Policy off my friends 7230 two days ago using your blank policy and registry edit.

John Clark 05-25-2008 09:29 PM

Go back and remove that policy. It's being applied to each BB you connect to the Desktop Manager. You ONLY want it applied to a BB that you are removing a more restrictive policy from. That's the last part of the instructions. ;-)

TroyDBrown 05-25-2008 09:50 PM

Quote:

Originally Posted by John Clark (Post 943819)
Go back and remove that policy. It's being applied to each BB you connect to the Desktop Manager. You ONLY want it applied to a BB that you are removing a more restrictive policy from. That's the last part of the instructions. ;-)

Thank you so much and please forgive me. I will forgive you for throwing me off by putting the final instruction in BOLD RED. :oops:

Chitown021 05-25-2008 10:49 PM

John, when I applied the procedure outlined in the OP should it have left the firewall option locked? Before I applied the fix the password was locked on ENABLE, the security timeout was locked on "2 MIN", and the firewall was locked on ENABLE. After I followed the steps firewall was the only option that remained locked.

jeffbutts 05-26-2008 10:32 PM

thanks
 
dont know if this will help but i was thinking it said .......rename path.now.......not rename path(.period)now.....:idea:

jeffbutts 05-26-2008 11:02 PM

i have done the steps over and over again to no result but i am getting this at the end of the last step can someone tell me what it is and how to fix it?my e mail is [email address] thanx
Warnings were encountered during the loading process:

The following modules could not be loaded because their digital signatures were invalid.

KnJCDE.cod

John Clark 05-27-2008 04:28 AM

Jeff, That is a module for Push To Talk. I'm not sure why it's telling you the signature is invalid, though. If you don't need it you can remove it using my method in my "Optimize your BB" thread. You can find a link to it in my signature.

John Clark 05-27-2008 04:29 AM

Quote:

Originally Posted by Chitown021 (Post 943891)
John, when I applied the procedure outlined in the OP should it have left the firewall option locked? Before I applied the fix the password was locked on ENABLE, the security timeout was locked on "2 MIN", and the firewall was locked on ENABLE. After I followed the steps firewall was the only option that remained locked.

Unless you are using the "resettofactory" method (only available on 4.3 and higher OS devices) you will NOT be able to unlock the firewall. Sorry....This is the best there is.

Chitown021 05-28-2008 02:30 PM

Quote:

Originally Posted by John Clark (Post 945056)
Unless you are using the "resettofactory" method (only available on 4.3 and higher OS devices) you will NOT be able to unlock the firewall. Sorry....This is the best there is.

Thanks John. That's what I was afraid you'd say. Maybe once my carrier updates to OS 4.3 I can use the other method and disable it then.

chm0690 05-29-2008 07:24 PM

Does this lead to the browser not being available. I have tried everything here and at what crackberry says to try and I do not have my media net or browser available to me. Any suggestions or am I just not following through on the steps here

John Clark 05-29-2008 07:31 PM

Go to Options >Advanced Options >Host Routing Table >Menu key (left of trackball) and select "Register Now." If you have a BB data plan that should bring back your browsers, etc.

chm0690 05-29-2008 07:45 PM

Appreciate the help. Finally found my problem plus with your input got my bb back to working condition. Might be a newbie mistake on my part, but JL_Cmder must be 1.9.0 for everything to work. I was using an older version of it. Once again thanks

rseem 06-01-2008 03:48 PM

Thanks so much for this thread and all the research and work that went into it. I found myself with an old IT policy on my 8100 after recently leaving my company. Following this approach with John's policy.bin freed up my 8100 nicely. I really liked that the policy.bin code is published so I could see the settings applied through it.

There is one area that is still not working however. I cannot enable Bluetooth access to the desktop manager. I have confirmed I have all the prerequiste software level etc and the problem seems to amount to the "Desktop Connectivity" and "Wireless Bypass" services not being enabled in the 8100's Bluetooth Options. This is fairly well discussed in threads on this and other forums as a common result of a IT Policy hangover.

In looking at the instructions on blackberry.com on how to enable bluetooth into desktop manager it talks about the IT Policy restrictions stating:
"If you have an account on a BlackBerry Enterprise Server, it must be running BlackBerry Enterprise Server software version 4.0.3 or later, and the following IT policies must be set to FALSE:
  • Disable Desktop Connectivity
  • Disable Wireless Bypass
Note: The two policies are located in the Bluetooth Policy Group. The default setting for these policies is TRUE."
Since my 8100 was subject to an old IT policy I am assuming the default settings of True are in effect to disable desktop connectivity and wireless bypass.

The article alludes to a "Bluetooth Policy Group" that can be set in the IT Policy. My ultimate question (thanks for the patience so far) is whether the current blank policy.bin code could be extended to have a "Bluetooth Policy Group" with settings of False for "Disable Desktop Connectivity" and "Disable Wireless Bypass".

Thanks again. It's great to have an apportunity to discuss this and I apologize if this is a redundant post.

John Clark 06-01-2008 08:56 PM

I understand the request. However, the code for the bluetooth is not in the policy creator I've used. It's simply the policy writer from BES express. If I knew what the code was it's possible that it could be inserted and compiled into the policy.bin. There is a thread going in the BBUnite forum about writing policies for BBUnite! and it's possible that one of those policies might do the trick. However, I've not looked at this in quite some time.

Once OS 4.5 comes out (it's out there in beta) you can use the resettofactory command in JL_Cmder to remove ALL policy and restrictions from the BB device. However, you have to have OS 4.3 or 4.5 loaded on the device.

jovi_iits 06-09-2008 11:55 AM

Hi John,

I tried to install your JL_Cmder v1.9.0.exe on my WindowsXP but I cannot see where it is to run the resetfactory command. Could you pls tell me more?

I installed the Desktop Manager 4.3 on laptop and current using BB8820, v4.2.2.193

Thanks a lot.

Regards,
jovi

John Clark 06-09-2008 03:28 PM

The 'resettofactory' command is part of JL_Cmder. When you run JL_Cmder you'll see it as an option. However, resettofactory will not work on your 8820. You need Handheld OS 4.3 or higher installed in order for the resettofactory command to work.

Blindsorcerer 06-10-2008 01:59 PM

Hey guys , nice forum , I would like to know if there's any copyright for the JL_Cmder ?

because I work in a large company and that would be a great tool for IT Policy removal

of our user who leave the company and are left with IT policy .

Alex

eazappi 06-17-2008 10:12 PM

Hello John
Hello All, My name is Eduardo, this is my first post.
Please, if I do something wrong forgive me and show me the proper way.
I have sent 2 private messges to you, well I think the proper way is post the message in the forum, first mstake, sorry for that
well, lets go to the questions.
Is the reason for I am not able to use wi-fi connection the ti policy of the company I work for?
Ok if I can not receive my email from wi-fi connection, but I would like to be able to browse the internet or use skype for instance.
Can the SMS text feature be controled by policy as well?
about the JL_Cmder
my 8320 is unlocked and was from T-Mobile I can not use
if I use this software to wipe handheld and install the lastest OS with vendor id and vendor.xml erased,
will it work without loose the unlock state?
T-mobile does not offer the 4.3 handheld software yet, can I use from blackberry webpage?
Thank you
Regards
Eduardo

John Clark 06-17-2008 10:37 PM

Your company can control almost any setting on your BB with their policy. I would check with them to see what they are restricting.

eazappi 06-17-2008 10:44 PM

Hi John
Thank you for you reply
I will check it out.
Regards
Eduardo

mettleh3d 06-18-2008 04:01 AM

This helped a lot thx!

passport2 06-18-2008 08:48 AM

Hi , John.. the usb cable should be connected during the entire operation?
thanks.

passport2 06-18-2008 08:54 AM

ResetToFactory on option 5

VJgamer 06-19-2008 02:13 PM

After doing resettofactory, I am still unable to have split-pipe connections with my firewall on. (it is so annoying having to say Yes every time I use an application that connects to the Internet when the firewall is off). I have a Sprint 8330. Is there anyway to fix this? Will the old method work for this?

VJgamer 06-19-2008 02:47 PM

Ok... Loading the blank (not blank because split-pipes are not allowed by default) policy.bin I can now use apps that use the interenet and the media card with no annoying prompts. Thanks John!

thefonedoc 06-28-2008 12:40 AM

John you're a star
Had firewall issues with mine which has the OS 4.5.0.37 on it now and after reading this its gone!!!

Bozo2007 06-28-2008 01:23 AM

I have spent days and days on this problem. After putting unite on my BB I decided to delete it. In doing so I now have a red lock on my firewall and can not disable it. Also my Bluetooth is messed up. I did the factory reset and everything was back to normal. I have wiped the bb...factory reset many times. As soon as I hook the BB up to DM the locked firewall comes back and the Bluetooth is messed up again. I have removed all refrences to Unite and have added the policy bin and removed it from my computer and the registry. Factory reset...everything perfect....hook up to DM....crap is back. So frustrating. Hope someone gets this figured out soon. By the way I have 8830 with 4.5 OS and 4.5 DM.

John Clark 06-28-2008 01:33 AM

You haven't completely removed Unite then...

You shouldn't be adding any policy.bin. BB Unite needs to be removed.

Bozo2007 06-28-2008 02:58 AM

Thats exactly what I thought John. BUT...I cant find any hint of the unite program.

Bozo2007 06-28-2008 03:20 AM

Just did a test. I resetfactory...firewall disabled...hook up to DM...it checked for updates. Unplug usb from BB. Checked. And there it was firewall enabled. I went over this computer with a fine tooth comb and there is nothing about unite. I checked registry to.

John Clark 06-28-2008 05:49 AM

There is an entire forum dedicated to BB Unite! I suggest going through the stickys and threads over there for the answers. You're missing something somewhere. Obviously the policy is still on the computer somewhere.

Bozo2007 06-28-2008 04:08 PM

I have read every post here and on other forums regarding Unite. It seems there are many people in the same boat as me. Here is one that makes you go hmmmmmm... I tried dm on another computer after I factory reset. Guess what? Yup ....same thing. Firewall was re enabled and locked.

John Clark 06-28-2008 05:30 PM

There have been many who have removed Unite, then removed the policy and all was well. I'm not sure why you're having such trouble. The ONLY way a policy can be put on the device to lock the firewall is if someone added the policy.bin in this post, added BBUnite, or is on a work PC connected to their email profile, etc.

I have several BB's I connect to my laptop and a policy is never put on the device.

Bozo2007 06-28-2008 05:57 PM

After I removed Unite and started having problems I loaded your policy.bin on. Since then I have removed from my pc and in registry. So something is really screwy.

John Clark 06-28-2008 06:01 PM

If you do a resettofactory there is no need for the policy.bin procedure. You sure you removed the policy.bin?

Bozo2007 06-28-2008 07:11 PM

Ya I removed it. No trace of it anywhere on my computer. Took out the path in registry as well.

Roll 06-28-2008 07:50 PM

John.... just a quick thanks for the update at the top of the thread. I thought I was doomed when I realized my firewall was enabled and locked. If I never see another BES it will be too soon. My 3rd party apps where choking and I was too.

Downloaded JL_Cmder and followed the instructions and wha-la my firewall is disabled and unlocked. Can't thank you enough.....

Gary

To be on the safe side I think I will uninstall DTMgr, clean up the registry, and start over on both PC's Home and work. This will be the 8th time I've done the DTMgr boogie, the 3rd time for the registry. These BB's are great but a lot of work.... LOL

John Clark 06-28-2008 07:59 PM

Wirelessly posted (BB 11020)

Glad it worked for you. I'm not sure what all the ruckus is about the firewall. It causes no issue for me and is a good protection for the device and keeps you updated with what apps are doing what. I have the firewall turned on on my devices that have no policy.

Roll 06-28-2008 08:22 PM

The problem for me was that Weatherbug, Audible air and google maps couldn't connect to the web and so would hang. Very annoying. I set permissions to "allow" but that didn't help.

I was fuming but now I'm a happy guy! :-)

Gary

John Clark 06-28-2008 09:46 PM

A reset of firewall prompts usually will take care of that. Most likely you accidentally hit deny when a prompt came up. I've found the firewall to work well except for OS 4.5, and BES application control policies with Google Maps 2.0 and above. That's a bug in 4.5 somewhere or Google Maps.

eatnaders 06-30-2008 01:20 AM

ITPolicy Tool
 
1 Attachment(s)
All,

Here is the IT Policy Tool. Enjoy.

John Clark 06-30-2008 01:31 AM

Thanks for the Tool. Where did you get this?

eatnaders 06-30-2008 01:37 AM

JL Commander
 
1 Attachment(s)
All,

Here you go.

eatnaders 06-30-2008 01:40 AM

I downloaded the BES Upgrade Tool from Blackberry.com and Extracted the CAB File to see the contents of the executables. There was a directory in there called ITPolicy. Oooops on Blackberry's part.

John Clark 06-30-2008 01:50 AM

We have the JL_Cmder application on the forum already. I just hadn't seen this particular ITPolicy tool. Thanks!

eatnaders 06-30-2008 01:52 AM

Anytime. I downloaded this tool today. I think it is pretty new.

John Clark 06-30-2008 01:53 AM

Actually, I have seen this. This looks like the same one I used to create the policy I have above. This is a newer version so I'll take a look and see if there's anything new from my older version. Thanks!

adhikariindia 06-30-2008 08:33 AM

i have removed the policy , you just haev to download a tiny file to your desktop. the location you save the file is (C:\Program Files\Research In Motion\BlackBerry). that means c drive. now just follow up the instruction, it will work i hope.

Bozo2007 07-01-2008 05:43 PM

I am soooooooooo frustrated with this. I can not get the firewall to stay unabled after a factory reset. It shuts off the firewall and fixes the bluetooth but as soon as I run DM it locks up again. I have completly removed policy.bin...DM...unite software....device os. and all refreneces to it in registry. Then I loaded a fresh DM 4.5 (after removing all rim directories) and a 4.5 os to my 8830. Reset to factory. Firewall is off...bluetooth works fine. As soon as I run DM it screws it up again. Firewall enabled...bluetooth doesnt sync to DM.

Bozo2007 07-01-2008 06:21 PM

And one other thing. Even though I have removed the policy.bin and the refrenece to it in registry it still shows as locked and the message This BB has a blank policy on it written by John etc. I'm about to toss this BB in the trash and go get a new 8330

John Clark 07-01-2008 07:09 PM

If your device says it has my policy on it then you still have the policy.bin on your computer somewhere. You need to locate it and find it. That is the ONLY explanation.

Any BB you connect to your computer will get that policy placed on it. Don't hook up another BB to it until you find it.

Bozo2007 07-01-2008 07:42 PM

I have done a complete search on my computer as well as my network and there is no policy bin anywhere.

John Clark 07-01-2008 07:44 PM

You're missing it somewhere. That's the ONLY way it can happen. It's on your PC somewhere. Did you do the exact reverse of the steps above? I have no idea where you put it on your PC but it's there somewhere. The ironic thing about it is with OS 4.5 you never needed my policy.bin in the first place.

John Clark 07-01-2008 07:45 PM

What you're getting is not a Unite! policy. It's the policy.bin YOU placed on the computer somewhere.

Bozo2007 07-01-2008 09:15 PM

Ok I will try this once more. There is no policy.bin within 200 miles of my house. hahahaha I give up. 2 weeks at this and still no solution. The fact there is a policy.bin on my bb indicates of course its picking it up from somewhere. Must be coming from mars but i dont know how my house is covered in tin foil.

John Clark 07-01-2008 09:18 PM

It's there...somewhere. I've done this before and removing the policy.bin from where I placed it and editing the registry to the way it was before has always worked and I never put a policy on accidentally.

Bozo2007 07-01-2008 10:13 PM

I did it!! Firewall unlocked and bluetooth workie!!
 
First off I would like to thank John for putting up with me. Here is what happened.

I decided to do a search for John Clark on my computer. A little file poped up called untiltled.inf. Low and behold this little file (John would know better then I) is the cfg file for policy.bin. I was playing around with the itpolicy exe and it created this file. So no matter how many times I deleted policy.bin itself somehow this untilted.inf was creating and adding to my BB. I deleted it. Checked my computer again and there it was....policy.bin sitting in an obscure hidden directory. One thing I should point out John in case it comes up again. This was vista and a lot of strange things happen with vista. I will source this out more and find out exactly why this was happening so no one else has to go through this.

John Clark 07-01-2008 10:18 PM

At the risk of sounding condescending (because I'm not) I wouldn't mess around with itpolicy.exe unless you know what you are doing. Someone posted it here and thats fine but this is what can happen.

A simple backup, resettofactory, and restore was all that was needed.

Bozo2007 07-01-2008 10:29 PM

The problems started with Unite software. By the time you figure out whats going on and reading the mis information as well as your good information you get frustrated. Then you start to try anything to get it to work. Vista doesnt help. Anyways....thanks John....the good news is I learned A LOT!!! ;-)

John Clark 07-01-2008 10:31 PM

That's why I mention the resettofactory method for OS 4.3 and higher first. You shouldn't have needed to read any further.

Glad you found it.

raymond11 07-02-2008 09:16 AM

Again, trouble started with unite! and I was going crazy. your post was great and now I feel like a new guy with a new phone. Unite is fine but it'll be for the bold or something else with wifi.

I con't thank you enough

nemogamo 07-08-2008 03:10 AM

Dear Jhon,
i have 8707g with Firewall anabled and its locked
its 4.2 OS version !
i follow exactly with your direction
but still can not getting done...
the firewall still enabled & locked
when i press the option-status & type BUYR
under IMEI :
Data Usage IT Policy Enabled
Voice Usage IT Policy Enabled

Is there any upgrade 8707 to 4.3 OS ?

John Clark 07-08-2008 03:15 AM

There is no OS 4.3 for the 8707.

The second method should work. However, you cannot unlock the firewall using the second method. The second method just puts a blank IT policy on the device so it will show that there's a policy.

nemogamo 07-08-2008 03:21 AM

Too bad..

I try the second method, but no luck
Still have an IT Policy Enabled.. :-(

John Clark 07-08-2008 03:28 AM

It will ALWAYS have an IT policy on it. There is no removing it COMPLETELY unless the device has 4.3 or higher. The best that can be done is the blank IT policy (method number 2) and that still leaves a policy, just the least restrictive available. The second method WILL NOT unlock the firewall. It can't be done unless the device has OS 4.3. I hope this is clear.

nemogamo 07-08-2008 03:38 AM

Its clear John, Thanks
now i have to look another way $$$

John Clark 07-08-2008 03:39 AM

Is the firewall locked to where you can't use it?

nemogamo 07-08-2008 04:38 AM

Opera mini can't install due to the firewall restrict

John Clark 07-08-2008 04:42 AM

What error message do you receive?

nemogamo 07-09-2008 02:54 AM

sorry for late reply, after several install attempt
finally the opera mini works...
but firewall still enabled and locked ;-(

lmq1985 07-11-2008 05:25 AM

question:what is IT policy ,and what will happen to my BB after remove IT policy

BigPete74 07-24-2008 03:19 PM

This is a great thread but I am having some issues. I would also like to curse BlackBerry Unite!

Ok, so I installed BlackBerry Unite to give it a try. I uninstalled it and, of course, I am not having the IT policy and Firewall enabled issue.

I have used JL Cmder to wipe my 8330 (Verizon). Once I did that the Unite IT policy no longer shows up Options -> General Security settings. However, typing in BUYR at the status screen still shows IT policy enabled. According to this thread, that's normal and you will never get that to say disabled. Is this correct?

Secondly, I am having issues with the Firewall. The Firewall shows enabled right now. Right after I do the JL Cmder restoretofactory, it shows as disabled. It seems to me that only after I enable my network connections does it become enabled. Is there a service book I can remove? If this is the problem how do I prevent it from being pushed to my BlackBerry?

How do I disable the firewall completely?

And before you guys ask. This is a brand new phone purchased from Verizon. It is not used and has never been used with BES. I am running 4.3 (4.3.0.127) on it.

sforget 08-10-2008 04:39 PM

Bell 6750 : unable to remove policy
 
Hi there! I was able to remove IT policies off 8700's from rogers, 7100's from nextel, 7250's from bell, 7290's from rogers and even 7750's from bell.....it seems somehow that it doesn't work with 6750's from bell since they use a 12pin com-type serial connection instead of USB. I tried downloading the most recent versions of blackberry desktop and device softwares and followed the same instructions as with the other models without results. I tried reinstalling the firmware a couple of times but it didn't work......I also tried wiping the device from the security menu, but it seems that it's not an available feature on this model. I'm desperately trying to find a workaround since I have at least 50 units that need to be wiped clean........Can anyone help me please?
Thanks
Simon

John Clark 08-10-2008 04:43 PM

Wirelessly posted (BB 11020)

No idea. I've never had one.


All times are GMT -5. The time now is 10:36 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.