View Single Post
Old 08-03-2012, 10:40 AM   #1
New Member
Join Date: Aug 2012
Model: 9780
Carrier: Telus
Posts: 3
Default Keyboard Presses different buttons along with the one I pressed.

Please Login to Remove!

So I've seen a lot of posts where people complain about stuttering. I however couldn't find anything about what my phone is doing.

When I press half the buttons on my keypad on my 9780, it will press another button along with it.

when I press 'e' i actually get 'oe' the same happens when I press 'o'
the same happens for 'i' and 'd'
'p' and backspace
'l' and 's'
'k' and uppercase (Bottom left)
'm' and 'z'
'x' and '$'

This make typing on my phone utterly impossible. The only thing i can do is type out a whole message the highlight and 'cut' the letters i don't want.

I ordered 2 replacement keypad membranes, replced it with precision, cleaned the contacts, pressed the thing down. And it worked for about an hour, now it will work sometime and not others mostly not working. Thinking I did something wrong, I replaced it again, cleaned it even better, and nothing different.

I've tried googleing this problem to no avail and was really hoping someone here could help me out.

Offline   Reply With Quote